博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
hdu 1950 Bridging signals(最长上升子序列)
阅读量:7237 次
发布时间:2019-06-29

本文共 3259 字,大约阅读时间需要 10 分钟。

Bridging signalsTime Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 447    Accepted Submission(s): 283

Problem Description
'Oh no, they've done it again', cries the chief designer at the Waferland chip factory. Once more the routing designers have screwed up completely, making the signals on the chip connecting the ports of two functional blocks cross each other all over the place. At this late stage of the process, it is too
expensive to redo the routing. Instead, the engineers have to bridge the signals, using the third dimension, so that no two signals cross. However, bridging is a complicated operation, and thus it is desirable to bridge as few signals as possible. The call for a computer program that finds the maximum number of signals which may be connected on the silicon surface without rossing each other, is imminent. Bearing in mind that there may be housands of signal ports at the boundary of a functional block, the problem asks quite a lot of the programmer. Are you up to the task?
01145524-13f90b086e984416b3a87f3304f05d8b.jpg
Figure 1. To the left: The two blocks' ports and their signal mapping (4,2,6,3,1,5). To the right: At most three signals may be routed on the silicon surface without crossing each other. The dashed signals must be bridged.
A typical situation is schematically depicted in figure 1. The ports of the two functional blocks are numbered from 1 to p, from top to bottom. The signal mapping is described by a permutation of the numbers 1 to p in the form of a list of p unique numbers in the range 1 to p, in which the i:th number pecifies which port on the right side should be connected to the i:th port on the left side.
Two signals cross if and only if the straight lines connecting the two ports of each pair do.
 
Input
On the first line of the input, there is a single positive integer n, telling the number of test scenarios to follow. Each test scenario begins with a line containing a single positive integer p<40000, the number of ports on the two functional blocks. Then follow p lines, describing the signal mapping: On the i:th line is the port number of the block on the right side which should be connected to the i:th port of the block on the left side.
 
Output
For each test scenario, output one line containing the maximum number of signals which may be routed on the silicon surface without crossing each other.
 
Sample Input
4
6
4 2 6 3 1 5
10
2 3 4 5 6 7 8 9 10 1
8
8 7 6 5 4 3 2 1
9
5 8 9 2 3 1 7 4 6
 
Sample Output
3
9
1
4
 
 
/*程序的主要过程:当循环到第i个的时候,如果原序列中的第i个数值大于之前d中保存的上升序列中长度最长的那个最后的值,那么,就把当前记录的最长的子序列的长度+1,然后把这个值加到d的末尾;如果不大于,那么就从前面二分找到这个值,d中的序列一定是有序的,找到d总刚刚大于它的那个值,替换掉。*/
 
#include <iostream>
#include <string>
#define maxn 40040
#define max(a, b) a > b ? a : b
using namespace std;
 
int a[maxn];
int f[maxn], ans;
 
int search( int x, int l, int r ){
    while ( l <= r ){
        int m = ( l + r )>>1;
        if ( f[m] < x ){
            l = m+1;
        }
        else{
            r = m-1;
        }
    }
    return l;
}
 
int main(){
    int T, n;
    scanf("%d", &T);
    while ( T-- ){
        scanf("%d", &n);
        for ( int i = 0; i < n; i++ ){
            scanf("%d", &a[i]);
        }
        int j = 0;
        f[0] = a[0];
        for ( i = 1; i < n; i++ ){
            if ( a[i] > f[j] ){
                f[++j] = a[i];
            }
            else{
                int d = search( a[i], 0, j );
                f[d] = a[i];
            }
        }
        printf("%d\n", j+1);
    }
}
 
 
 
 
 

转载于:https://www.cnblogs.com/weibingkitty/p/3294519.html

你可能感兴趣的文章
notepad++ plugins manager 无法下载插件
查看>>
基本数据结构 -- 树简介
查看>>
【Codeforces Round #405 ( Div 2)】题解
查看>>
虚拟磁盘工具vmkfstools的使用
查看>>
HP LaserJet Pro P1106网络打印机64位驱动安装
查看>>
【博客话题】我的linux戏曲
查看>>
继之前SCVMM WinRM问题后重新添加群集后Windows Azure Pack创建虚拟机失败
查看>>
第十六集被忽视的帧中继:原理及实验
查看>>
关于Ubuntu上Eclipse不显示手机设备
查看>>
iPhone的Push(推送通知)功能原理浅析
查看>>
Oracle 11g Release 1 (11.1) 游标——SQL 游标(隐式)
查看>>
欧拉函数
查看>>
用groovy写抓票程序
查看>>
设计资源推荐-20个漂亮的免费PSD图标格式
查看>>
学用MVC4做网站:序
查看>>
mysql kill操作
查看>>
Go Revel - i18n(国际化)
查看>>
MVC应用程序JsonResult()的练习
查看>>
VBS解析时候遇到时间
查看>>
Android应用公布的准备——渠道注冊与认证
查看>>